Last visit was: Sun Oct 25, 2020 8:45 am It is currently Sun Oct 25, 2020 8:45 am

All times are UTC+01:00




 [ 5 posts ] 
Author Message
PostPosted: Wed Jul 15, 2020 12:52 pm 
Offline
User avatar

Joined: Fri Jul 10, 2015 3:57 pm
Posts: 55
Current ride: XB9R
Location: Northants
Hello all, my oil pump has gone again so I reckon the gear drive to it must have been worse than it looked. I got to the Isle o' Man and back so happy days.
I need another oil pump and the oil pump drive gear. I could do with the Timing gear cover too as I've replaced the seal behind the ignition a couple of times but it just won't seal fully.
Anyone got any of these bits for sale? Prob gonna need some gaskets for exhaust header, timing gear cover and rocker covers. 2002 XB9R
Thanks
Pon x


Top
   
 
PostPosted: Wed Jul 15, 2020 1:35 pm 
Offline
Moderator
User avatar

Joined: Wed Apr 15, 2009 5:25 pm
Posts: 11835
Location: Oswestry
I'd try and salvage your existing cover for the timing chest. A new one may well not be 'matched' to your cases. You may be lucky!

_________________
If your dreams don't scare you, they are not big enough.


Top
   
 
PostPosted: Wed Jul 15, 2020 2:15 pm 
Offline
Site Admin
User avatar

Joined: Wed Apr 15, 2009 5:17 pm
Posts: 8466
Location: Manchester
Riders of Bristol.
DO NOT replace the cover as it won't match the crankcase.....reason the seal keeps leaking is because you're not fitting it properly.
Did the drive gear break up ?.....if so, make sure you get all debris from the swingarm and lines.

_________________
Mithered ta death.
92 MB
96 S2T
98 S1W
00 M2
01 X1
03 P3
10 CR


Top
   
 
PostPosted: Wed Jul 15, 2020 3:06 pm 
Offline
User avatar

Joined: Fri Jul 10, 2015 3:57 pm
Posts: 55
Current ride: XB9R
Location: Northants
Maz wrote:
Riders of Bristol.
DO NOT replace the cover as it won't match the crankcase.....reason the seal keeps leaking is because you're not fitting it properly.
Did the drive gear break up ?.....if so, make sure you get all debris from the swingarm and lines.

I changed the oil pump last year cos it was leaking bad at the angled down union on the front. When I got the old pump apart both gerotors were cracked, no bits though really. I took some photos of the drive gear and it looked and felt OK so I put a used pump on and went to the IOM I've done less than 1k miles and this pump it gave up when I was nearly home last week about 5 miles.The pushrods were rattling bad. Pump apart and I couldn't turn it by hand, a fair bit of small debris in this one. Gerotors all narled up and the top of the drive looks worn. I've probably fucked it, time will tell. Thanks for the heads up on the cover.


Top
   
 
PostPosted: Wed Jul 15, 2020 3:07 pm 
Offline
User avatar

Joined: Fri Jul 10, 2015 3:57 pm
Posts: 55
Current ride: XB9R
Location: Northants
Adam wrote:
I'd try and salvage your existing cover for the timing chest. A new one may well not be 'matched' to your cases. You may be lucky!

Thanks for the heads up.


Top
   
 
 [ 5 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Limited