Last visit was: Tue Nov 13, 2018 7:25 am It is currently Tue Nov 13, 2018 7:25 am

All times are UTC+01:00




 [ 10 posts ] 
Author Message
PostPosted: Thu Oct 25, 2018 12:50 pm 
Offline

Joined: Thu Oct 25, 2018 11:57 am
Posts: 2
Current ride: Buell XB12X Ulysses
Afternoon all and thanks for the add.

I'm in need of desperate advice in regards to my '07 xb12x Ulysses. Although it's one of the most fun bikes I've ever ridden, it's driving me insane. I have 2 problems.

The first is causing the headaches - Once the bike is fully warm it suddenly dies. It may just be coincidence but both times have been whilst coming to a stop and going into 1st after a mile or two. The revs instantly drop to zero and I get nothing from it. It then takes a good 5-10 minutes for it to start back up, making me think it's the timing sensor (this sensor didn't change and split to a cam angle and crank sensor til '08). The part is £200 so I don't want to buy this until I'm certain it's the cause. The bike does have a higher seat fitted and I've double checked the ecm and can't find any hairline cracks on it as some say. I've tried tapping the ecm with the butt of a rubber-handled ratchet whilst running to try rule that out as well. All grounds have been cleaned and I've relocated the ecm to make sure nothing is rubbing but to no avail.

My other issue is the bike won't connect to diagnostics software no matter what I try. I've been using Diag4bike and their website has been no help either. However the issue of not connecting to diagnostics is making me think a ecm issue is the cause?

Any help on either matter would be incredibly helpful! TIA :ffs:


Top
   
 
PostPosted: Thu Oct 25, 2018 1:00 pm 
Offline
User avatar

Joined: Wed May 06, 2009 6:54 pm
Posts: 1553
Current ride: Triumph ST - RS
Location: West Lothian, Bonnie Scotland
Welcome :yup:

They'll be some clever folk along soon who will no doubt be able to sort you out.

Maz in Manchester is the Buell Yoda so if all else fails you can take it there for some pampering and a good looksee.

_________________
Better to Burn Out Than Fade Away

In the garage -

2001 X1
EBR 1190SX
KTM390 Duke
Triumph Street Triple RS
Ducati 1199
CCM Spitfire Scrambler


Top
   
 
PostPosted: Thu Oct 25, 2018 5:06 pm 
Offline
User avatar

Joined: Tue May 05, 2009 8:00 pm
Posts: 8992
Current ride: X1 2001 White Riot
Location: southampton
welcome to the site.

click on this link & scroll down , there's a way to read fault codes manually
without using any software...

viewtopic.php?f=17&t=807 :here:

so when it cuts out, does the starter spin over ?
is the fuel pump priming ?
have you tried taking the fuel cap off to see if there's an air lock ?
wiggling cables around the head stock area , in case of broken cables ?
sounds like you are already aware of the seat ecm issue
maybe better trying ecm spy

:yup:

_________________
Obey the principles without being bound by them.
Bruce Lee


Top
   
 
PostPosted: Thu Oct 25, 2018 8:08 pm 
Offline
User avatar

Joined: Mon Nov 07, 2011 7:10 pm
Posts: 2230
Current ride: Buell ulysses
Location: Telford
welcome :yup:
most people use http://www.ecmspy.com/

_________________
Buell Ulysses XB12X 06/08
CCM R30 (650cc) 02
Norton Dominators ( in bits on going projects ) old


Top
   
 
PostPosted: Thu Oct 25, 2018 8:20 pm 
Offline
User avatar

Joined: Fri Mar 11, 2016 7:28 pm
Posts: 814
Current ride: 1125r XB12X
Location: South
Welcome!


Top
   
 
PostPosted: Fri Oct 26, 2018 8:05 am 
Offline

Joined: Thu Oct 25, 2018 11:57 am
Posts: 2
Current ride: Buell XB12X Ulysses
Really appreciate the help guys! i'll give ecm spy a go!

It's not actually shown any codes as of yet but i'm hoping there's something hidden!

If i can't connect to ECM spy either would that more so be an ECM issue causing all of this?


Top
   
 
PostPosted: Fri Oct 26, 2018 9:07 am 
Offline
User avatar

Joined: Mon Nov 07, 2011 7:10 pm
Posts: 2230
Current ride: Buell ulysses
Location: Telford
if you can connect to ECM spy and get a log file of the bike running and with the cut out fault , then try and contact Pash ,he is the local master of ECM spy :worthy:

_________________
Buell Ulysses XB12X 06/08
CCM R30 (650cc) 02
Norton Dominators ( in bits on going projects ) old


Top
   
 
PostPosted: Fri Oct 26, 2018 3:46 pm 
Offline

Joined: Fri Jul 20, 2012 11:20 pm
Posts: 995
Current ride: 2001 X1//TRK 502x
Location: surrey
Hi, I'm not familiar with the XB. Models, however I did suffer a similar problem with my X11. It turned out to be the temp sensor. It would run fine for around ten miles then go all fluffy as if the choke was on then die. As folk have said. A visit to the emporium should be on your list. Even if the bike was running fine. An education awaits you. Believe me it's the best investment for your bike you'll ever make .


Top
   
 
PostPosted: Fri Oct 26, 2018 5:46 pm 
Offline

Joined: Tue Jun 08, 2010 4:34 pm
Posts: 640
Current ride: m2 cyclone
Location: leicester
Yay...an unknown buell ....x11 :rotfl:


Top
   
 
PostPosted: Sat Oct 27, 2018 7:15 am 
Offline
User avatar

Joined: Mon Nov 07, 2011 7:10 pm
Posts: 2230
Current ride: Buell ulysses
Location: Telford
thought that was an X1 that had been to the emporium :maz: and had all the faults put right and rebuilt correctly , now called an X11 :yup:

_________________
Buell Ulysses XB12X 06/08
CCM R30 (650cc) 02
Norton Dominators ( in bits on going projects ) old


Top
   
 
 [ 10 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Limited