Last visit was: Thu Oct 01, 2020 5:45 am It is currently Thu Oct 01, 2020 5:45 am

All times are UTC+01:00




 [ 27 posts ]  Go to page 1 2 Next
Author Message
PostPosted: Mon Jun 03, 2019 9:38 pm 
Offline

Joined: Fri May 10, 2019 11:31 pm
Posts: 45
Current ride: XB12XT
Sorry if this is a simple question - I'm a Buell newbie having just bought a 2009 Ulysses.

I'm considering refitting my standard muffler, with valve cable (replacing a Stealth), then I want to reflash the (tweaked, unknown map) ECU to standard too. All to cure rough/snatchy running below 2.5K; above that it seems fine. Had the bike looked over professionally so assume fuel pump etc. are OK, no air leaks found.

How is ECU programming done? ECMSpy appears to be a logger with the ability to tweak the map but not write a whole map (is that correct?) Is there a specialist somewhere or can I do this myself (what kit do I need?) or go for help from our resident gurus Gunter and Pash?

Many online posts are now so old that the kit is no longer available.

Apologies if this has been asked a million times before - I looked but couldn't find anything easily.

Cheers.

A


Top
   
 
PostPosted: Mon Jun 03, 2019 10:04 pm 
Offline
User avatar

Joined: Tue May 05, 2009 8:00 pm
Posts: 9938
Current ride: X1 2001
Location: southampton
it may just need a TPS reset :yup:
i would give it a try first , before swapping exhausts etc.
viewtopic.php?f=17&t=13


Top
   
 
PostPosted: Mon Jun 03, 2019 10:30 pm 
Offline

Joined: Sat Apr 06, 2019 5:14 pm
Posts: 52
Current ride: Ulysses XB12XT
Location: Cumbria
Have the earths been cleaned up? I’ve heard that can make a difference. I’m about to ‘reinforce’ the earths on mine using copper cable. Expecting an order from Vehicle Wiring Products in the next day or two. :D

_________________
‘08 XB12XT, ‘04 TDM900 & ‘84 XL600R


Top
   
 
PostPosted: Mon Jun 03, 2019 10:52 pm 
Offline

Joined: Fri May 10, 2019 11:31 pm
Posts: 45
Current ride: XB12XT
I'll give a TPS reset a go - much simpler on 08- bikes. Fairly sure the professional will have done this already but you never know!

Battery leads were loose but I tightened them and it made no difference, may clean up earths but the bike is in good condition - never been underwater!

Thanks for the help so far.

A


Top
   
 
PostPosted: Tue Jun 04, 2019 7:11 am 
Offline
User avatar

Joined: Mon Nov 07, 2011 7:10 pm
Posts: 3116
Current ride: Buell ulysses
Location: Telford
welcome :yup:
there are professionals and there are professionals :headbang:
reference to fueling then yes Pash and Gunter are the real Professionals :worthy:
TPS reset take it for a decent ride to get it nice and warm and give the ECU time to adjust it's self . check AFV values 100% + or - about 10% should be ok.
they can be a bit lumpy around 2000 rpm on light throttle .
if your are close to Manchester then call and see :maz: :worthy:
he has also got on open day in early July when other Buell owners turn up and compare bikes ..stories lOl

_________________
Buell Ulysses XB12X 06/08
CCM R30 (650cc) 02
Norton Dominators


Top
   
 
PostPosted: Wed Jul 08, 2020 9:56 am 
Offline

Joined: Fri May 10, 2019 11:31 pm
Posts: 45
Current ride: XB12XT
Thread resurrection....

Got the Uly out after the lockdown - great to be riding again although it still farts around a bit at low revs, but fine at higher revs. Fan runs when hot even though I'm not thrashing it.

Thought I'd learn a bit more about ECMSpy etc so I've logged (ECMDroid & Buelltooth) a recent ride (file attached in case a nice person wants to have a peek!) and managed to get MegaLogViewer to work to see the parameters.

I'm sure the fuel map is the OE one (laboriously compared front and rear with a factory file for BUEZD).

So - questions -

1. AFV is ALWAYS 100. Never less, never more.
Is there a setting that fixes it to a certain setting (100) that I can undo?
I thought it should vary as required (and maybe keep the engine cooler).

2. Is it normal for the fan to run continuously (for 15-20 minutes (or more) whilst riding on A roads, 50-70MPH)?
On temp is set to 220C, off temp is 180C - highest temp logged was 240C!
Seems hot to me although factory ultimate cutoff is 325C (when engine shuts down).

After that ride, I've fitted the additional earth wiring (headstock, coil and starter lead from centre tie bar, all direct to battery -ve) per this thread
https://www.buellxb.com/forum/showthrea ... hy-and-How

Done TPS reset but still have to change spark plugs (front has rust on it!) - ordered NGK Iridiums.

All help greatly appreciated (calling Gunter and Pash!)

Cheers,

A


You do not have the required permissions to view the files attached to this post.


Top
   
 
PostPosted: Wed Jul 08, 2020 10:52 am 
Offline
User avatar

Joined: Mon Nov 07, 2011 7:10 pm
Posts: 3116
Current ride: Buell ulysses
Location: Telford
Hi Andysdad
My understanding of fuel system is
So long as all else is ok ( temp sensor , lambda sensor ) and you did ride in the closed or open loop test method seelink
Then 100% means the fuel map is ok , if it was not it would of adjusted up or down to maintain a correct air fuel ratio to adjust for free flowing exhaust or air filter .
The fan around town caught in traffic will come on from time to time , but out in the country and in free flowing cooling air and gentile riding the fan should be off and quiet , yes if you get stuck at traffic lights in last week’s high summer temps , then the heat will quickly build up and fan will start.
(I have a right hand air scoop on mine to help cooling :yup: )
Pash is our local Buell ecmspy fuel specialist :worthy: .based around the Bristol area , and he lokes cake lOl or :maz: :worthy: up at Manchester , well worth a trip out to see them :idea:

_________________
Buell Ulysses XB12X 06/08
CCM R30 (650cc) 02
Norton Dominators


Top
   
 
PostPosted: Wed Jul 08, 2020 11:26 am 
Offline
Site Admin
User avatar

Joined: Wed Apr 15, 2009 5:17 pm
Posts: 8462
Location: Manchester
If it's bang on 100% I'd bet someone has locked it ?

_________________
Mithered ta death.
92 MB
96 S2T
98 S1W
00 M2
01 X1
03 P3
10 CR


Top
   
 
PostPosted: Wed Jul 08, 2020 12:25 pm 
Offline

Joined: Fri May 10, 2019 11:31 pm
Posts: 45
Current ride: XB12XT
Barney & Maz,

Thanks for answering.

Barney - the fan staying on is due to (over?) high temps; I reckon a proper tune might sort it out. The bike rides well (apart from low speed stumbles (plugs?)). All standard (air filter, exhaust).

Maz - that's my suspicion - exactly 100 all the time, never even 99.9 or 100.1. How is it locked?

I may PM Pash (he sold me the diagnostic lead); I'll get the new plugs in first.

Thanks again,

A


Top
   
 
PostPosted: Fri Jul 10, 2020 2:49 pm 
Offline

Joined: Fri May 10, 2019 11:31 pm
Posts: 45
Current ride: XB12XT
Another question...

I have acquired a BUE2D ECM (off a Uly NOT 1125); I presume this is "better" than the BUEZD original on the bike and will run without modification.

Buelltooth's website talks about flashing ECMs firmware to a later version (e.g. to BUE2D) so I think that the above is correct.

Right or wrong?

If right, it means my ECMSpy will no longer work as it is locked to BUEZD!

Did the ECM change for the 2010 engine with 2 O2 sensors? If so at which release? (BUE2D or BUE3D?)

Cheers all,

A


Top
   
 
PostPosted: Tue Jul 14, 2020 5:41 pm 
Offline
User avatar

Joined: Wed May 06, 2009 5:28 pm
Posts: 7135
Current ride: Muffin 2001 X1
Andysdad wrote:
Another question...

I have acquired a BUE2D ECM (off a Uly NOT 1125); I presume this is "better" than the BUEZD original on the bike and will run without modification.

Buelltooth's website talks about flashing ECMs firmware to a later version (e.g. to BUE2D) so I think that the above is correct.

Right or wrong?

If right, it means my ECMSpy will no longer work as it is locked to BUEZD!

Did the ECM change for the 2010 engine with 2 O2 sensors? If so at which release? (BUE2D or BUE3D?)

Cheers all,

A

Be very very very careful of any maps and downloads from the Buelltooth website , there are a lot of good Buell guys that would never touch his maps and one of his favourite things he does is to lock the afv . You need to download a known good genuine map and start from there , Pash is the best guy to chat to and might be able to tell you if what you already have is correct.

_________________
2001 X1 2009 1125CR 2006 Uly X2 and a fully Maz'd S1


Top
   
 
PostPosted: Tue Jul 14, 2020 10:24 pm 
Offline

Joined: Fri May 10, 2019 11:31 pm
Posts: 45
Current ride: XB12XT
Kevmean,

Thanks for the advice. My problem has been trying to find genuine factory maps/EEPROMS. A lot of the better sites no longer exist (e.g. Xopti).

I note your comments on Buelltooth; any ideas where I can find good maps now?

I've looked but cannot see how to unlock AFV from 100 - please can someone tell me how to do that?

Cheers,

A


Top
   
 
PostPosted: Thu Jul 16, 2020 3:24 pm 
Offline

Joined: Thu Feb 21, 2019 1:15 am
Posts: 35
Current ride: Ulysses XB12X
Maz wrote:
If it's bang on 100% I'd bet someone has locked it ?


mine looks the same - 100.0 for AFV and seem to recall PO talking about getting map - it does seem to run okay though - would it be recommended to get a 'clean' original 2006 Uly map?

thanks
Muir


Top
   
 
PostPosted: Wed Aug 05, 2020 11:16 am 
Offline

Joined: Fri May 10, 2019 11:31 pm
Posts: 45
Current ride: XB12XT
Still working on getting my Uly sorted.

Please can anyone comment on the questions below?

1. Can I straight-swap my BUEZD ECU for a newer BUE2D ECU? I'm sure the engine is unchanged between versions. Surely the newer tune is better?

2. I set the AFV to 105 but it reset to 100 within a minute of start-up. May be that it is just right.

3. AFR front to rear varies massively. AFR1 on a recent ride never went below 100 and max = 117 BUT AFR2 on that run ranged from 39 to 77. E.g. when hot, AFR1 =107 but AFR2 = 50.

I've replaced the plugs with NGK Iridium and put all new earth leads to avoid frame earth connection problems; bike fires up better but still stutters c.2K RPM especially when cold.

Sorry to be dumb but I'm trying to learn.

Many thanks in advance.

A


Top
   
 
PostPosted: Sat Aug 08, 2020 9:56 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14728
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
1. Yes

2. You should leave the AFV alone, the ECM knows more about fuelling than anybody else.

3. AFV? Not sure the ECM will let the AFV go much below 80, if at all.

I would stick to the 10R12X plugs to be honest. I've never used Iridium plugs, but I've heard from lots of people that have issues with them.

Andysdad wrote:
Still working on getting my Uly sorted.

Please can anyone comment on the questions below?

1. Can I straight-swap my BUEZD ECU for a newer BUE2D ECU? I'm sure the engine is unchanged between versions. Surely the newer tune is better?

2. I set the AFV to 105 but it reset to 100 within a minute of start-up. May be that it is just right.

3. AFR front to rear varies massively. AFR1 on a recent ride never went below 100 and max = 117 BUT AFR2 on that run ranged from 39 to 77. E.g. when hot, AFR1 =107 but AFR2 = 50.

I've replaced the plugs with NGK Iridium and put all new earth leads to avoid frame earth connection problems; bike fires up better but still stutters c.2K RPM especially when cold.

Sorry to be dumb but I'm trying to learn.

Many thanks in advance.

A

_________________
08 Specialized Langster


Top
   
 
 [ 27 posts ]  Go to page 1 2 Next

All times are UTC+01:00


Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Limited