X1 intermittant cutting out

Playground of the Techies. The place for resolution of more detailed questions and problems. Attempts to start The Tyre Thread or The Oil Thread in here may result in personal injury.
User avatar
pash
proff. patpending
Posts: 14705
Joined: Wed May 06, 2009 8:20 pm
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good

Re: X1 intermittant cutting out

Postby pash » Sat Jul 18, 2020 8:46 am

08 Specialized Langster

Clanger1
Posts: 23
Joined: Wed May 07, 2014 11:08 pm
Current ride: 2000 X1
Location: Northants

Re: X1 intermittant cutting out

Postby Clanger1 » Sun Jul 19, 2020 11:32 pm

pash wrote:Manuals...

viewtopic.php?f=8&t=12414

You beauty, Perfick!
2000 X1

Clanger1
Posts: 23
Joined: Wed May 07, 2014 11:08 pm
Current ride: 2000 X1
Location: Northants

Re: X1 intermittant cutting out

Postby Clanger1 » Thu Jul 30, 2020 11:40 pm

Well i got back to this today and it turned out it was the bank angle sensor. So edd and Kevmean were on the money thanks. I unplugged it and apart from the expected red check light all is good , did 30 odd miles this evening and didn't miss a beat.

So next question, where can i get a new sensor? Is it a generic part? Is there a work around?

Thanks.
2000 X1

User avatar
Maz
Site Admin
Posts: 8591
Joined: Wed Apr 15, 2009 5:17 pm
Location: Manchester

Re: X1 intermittant cutting out

Postby Maz » Fri Jul 31, 2020 12:35 pm

EcmSpy will delete the BAS.
Mithered ta death.
92 MB
96 S2T
98 S1W
00 M2
01 X1
03 P3
10 CR

Clanger1
Posts: 23
Joined: Wed May 07, 2014 11:08 pm
Current ride: 2000 X1
Location: Northants

Re: X1 intermittant cutting out

Postby Clanger1 » Sat Aug 01, 2020 12:24 pm

That would be a good solution, i have ecmspy but I've only ever used to read/clear codes or Tps reset. I’d need a few pointers to delete Bas settings ....
2000 X1

Clanger1
Posts: 23
Joined: Wed May 07, 2014 11:08 pm
Current ride: 2000 X1
Location: Northants

Re: X1 intermittant cutting out

Postby Clanger1 » Sun Sep 13, 2020 6:58 pm

Well famous last words but i seem to have sorted this. Inspired by disgruntled sportster owners who had the same problem I gutted the BAS and played around with some resistors to get the required ~1V going back to the ECU. I ended up with 11k between 12v pin and ecu pin. And then 1k from ecu pin to earth pin. Engine now running closed loop again and no check light. These weren’t the values the Harley boys used but works for me.
2000 X1

User avatar
Nutah
Posts: 10469
Joined: Tue May 05, 2009 8:00 pm
Current ride: X1 2001
Location: southampton

Re: X1 intermittant cutting out

Postby Nutah » Sun Sep 13, 2020 10:07 pm

:yup: nice result
Feros Ferio

gusm2
Posts: 2240
Joined: Wed May 06, 2009 5:10 pm
Current ride: 99 Cyclone M2
Location: Liverpool

Re: X1 intermittant cutting out

Postby gusm2 » Sun Sep 13, 2020 10:20 pm

:yup: result
Last year I joined a group for anti-social people
We haven't met yet.

User avatar
Maz
Site Admin
Posts: 8591
Joined: Wed Apr 15, 2009 5:17 pm
Location: Manchester

Re: X1 intermittant cutting out

Postby Maz » Sun Sep 13, 2020 11:39 pm

So why didn't you just disable the BAS using EcmSpy ?
Mithered ta death.
92 MB
96 S2T
98 S1W
00 M2
01 X1
03 P3
10 CR

Clanger1
Posts: 23
Joined: Wed May 07, 2014 11:08 pm
Current ride: 2000 X1
Location: Northants

Re: X1 intermittant cutting out

Postby Clanger1 » Mon Sep 14, 2020 12:27 am

Because as i stated before I have no idea how to do that and no one offered to help.
2000 X1

User avatar
conquistador
Posts: 843
Joined: Wed May 06, 2009 2:02 pm

Re: X1 intermittant cutting out

Postby conquistador » Tue Nov 30, 2021 6:30 pm

Bizarre coincidence, was just reading this thread last week and hey presto my bas has packed up. To make it worse my laptop has also gone faulty so couldn't even access the ecu... :cry:
2001 X1
2001 M2
2017 Street Triple RS
Wilier La Triestina
Scott CR1

User avatar
kevmean
Posts: 7229
Joined: Wed May 06, 2009 5:28 pm
Current ride: 1991 RS1200 westwind

Re: X1 intermittant cutting out

Postby kevmean » Thu Dec 02, 2021 2:07 pm

conquistador wrote:Bizarre coincidence, was just reading this thread last week and hey presto my bas has packed up. To make it worse my laptop has also gone faulty so couldn't even access the ecu... :cry:

Just unplug it for now it won't affect the running ;)
2001 X1 2009 1125CR 2006 Uly X3 2010 Uly a fully Maz'd S1 and a 1991 RS1200 Westwind.

User avatar
conquistador
Posts: 843
Joined: Wed May 06, 2009 2:02 pm

Re: X1 intermittant cutting out

Postby conquistador » Thu Dec 02, 2021 8:17 pm

I have done, that's how I traced the fault.
2001 X1
2001 M2
2017 Street Triple RS
Wilier La Triestina
Scott CR1


Return to “Technical Forum”

Who is online

Users browsing this forum: Brandwatch [Bot], CommonCrawl [Bot] and 2 guests