Fitting LED Indicator bulbs to Ulysses

Playground of the Techies. The place for resolution of more detailed questions and problems. Attempts to start The Tyre Thread or The Oil Thread in here may result in personal injury.
Andysdad
Posts: 64
Joined: Fri May 10, 2019 11:31 pm
Current ride: XB12XT

Fitting LED Indicator bulbs to Ulysses

Postby Andysdad » Sun Apr 10, 2022 9:30 pm

Had 2 10W bulbs blow in 2000 miles, so decided to go LED.

Sorry if this has been posted before; I looked but could not find a similar post.

Buying the LED bulbs is easy enough (eBay) but the factory flasher unit will flash too fast as the current is much less.

I found this relay on Amazon for £6 delivered; called a CF14 it is plug replacement for the factory unit and works with both LED and standard bulbs because it does not use current to set the flash-rate.

https://www.amazon.co.uk/Flash-Signal-C ... B00FGRGBXM

I ran a bead of black silicone across the top plate/case joint to waterproof it. There is no bracket but a tie-wrap works.

HTH

A

User avatar
jeznewsome
Posts: 650
Joined: Tue Jun 23, 2009 12:55 pm
Current ride: S1W,SDGT,HP2,R1200RS
Location: Preston, Lancs

Re: Fitting LED Indicator bulbs to Ulysses

Postby jeznewsome » Sun Apr 10, 2022 9:36 pm

:yup:

User avatar
Nutah
Posts: 10469
Joined: Tue May 05, 2009 8:00 pm
Current ride: X1 2001
Location: southampton

Re: Fitting LED Indicator bulbs to Ulysses

Postby Nutah » Mon Apr 11, 2022 12:25 pm

:yup: nice one
Feros Ferio


Return to “Technical Forum”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 2 guests